php升级版本后导致的500错误

php升级版本后导致的500错误

centos+lnmp+wordpress的组合,有时候会出现403错误,发现这个组合下没啥好的解决方法,有人说更新php版本有奇效,这也是成本最低的方案了,遂折腾之
lnmp更新php非常方便,upgrade.sh php,升级脚本人家都写现成的
升级后问题来了,探针正常,但wordpress 500错误,试用了治百病的重启大法,无果
怀疑php-fpm的php-cgi.sock不正确,但是探针能访问,说不过去,排查了也没发现问题
nginx日志能看到500,但是看不到更多细节,php日志也看不到有价值信息
由于只变更了php,想到了是不是php.ini配置有什么变化引起的问题,索性upgrade脚本自动备份了php
对比php.ini


至此,破案,之前折腾zlib时,改了php.ini,升级后的php.ini zlib没开,导致500,恢复php.ini后正常

0 条评论

What is 6 + 14 ?
Please leave these two fields as-is:
不答对这道小题,是不给通过的哦

昵称

此站点使用Akismet来减少垃圾评论。了解我们如何处理您的评论数据

沙发空缺中,还不快抢~